Username: Password: Remember me
Search + Advanced
Package Details

arduino 1.8.7-1
https://github.com/arduino/Arduino
Arduino prototyping platform SDK

Category: devel

Submitter:
Maintainer: AlmAck
Votes: 3

License: GPL LGPL

Last Updated: 2018/11/04 - 12:49:57 +0000
First Submitted: 2012/07/20 - 12:13:35 +0000

Tarball :: PKGBUILD

Dependenciesavrdudedesktop-file-utils giflib gtk2 java-runtime libusb-compat 

Sources

Comment by: yoalieh on Fri, 16 Jan 2015 19:31:55 +0000


Hi, new version in AUR requires java-rxtx to work.  I added it to CCR.

Comment by: yoalieh on Fri, 16 Jan 2015 17:24:48 +0000


You can add a dependency to icoutils and run 

icotool -x --index=10 /usr/share/arduino/lib/arduino_icon.ico -o /usr/share/pixmaps/arduino.png

to get the icon working

Comment by: leozzo on Sun, 19 Jan 2014 14:15:11 +0000


Package updated
Thank you for reporting the issue.

Comment by: CTown on Tue, 07 Jan 2014 00:32:13 +0000


Hello, can you please add 'staticlibs' to the options array in the PKGBUILD so makepkg stops getting rid of the static libraries needed by the IDE. Otherwise, it the IDE just throws this error when compiling:

"...bin/ld: cannot find -lm"

Here is a thread about the problem: http://chakra-project.org/bbs/viewtopic.php?id=12547

Comment by: Ram-Z on Tue, 12 Nov 2013 23:10:52 +0000


In the following thread we announced that GTK application will no longer reside in /extra.
http://chakra-project.org/bbs/viewtopic.php?id=12118

This package seems to be installed into /extra or depend on filesystem-extra.

Please adapt your PKGBUILD:
1. install into /
2. remove the dependency on filesystem-extra

PS: The list of packages still using /extra has been generated automatically, and this comment sent in bulk. If you think it was sent in error, just ignore it, or contact me or any other TU.

Comment by: leozzo on Sun, 02 Jun 2013 13:52:48 +0000


Package updated

Comment by: CybrixSystems on Sun, 26 May 2013 19:10:58 +0000


Please update PKGBUILD to support /extra