Username: Password: Remember me
Search + Advanced
Package Details

teamviewer 14.1.3399-9
http://www.teamviewer.com
All-In-One Software for Remote Support and Online Meetings

Category: network

Submitter: Pyrdracon
Maintainer: None
Votes: 11

License: custom

Last Updated: 2019/01/06 - 17:50:09 +0000
First Submitted: 2013/02/22 - 11:28:26 +0000

Tarball :: PKGBUILD

Dependencieshicolor-icon-theme qt5-quickcontrols qt5-webkit qt5-x11extras 

Sources

Comment by: Tux83 on Sun, 25 Nov 2018 16:30:34 +0000


Updated to version 14!

Comment by: Pyrdracon on Fri, 20 Jan 2017 14:11:14 +0000


@dinolib: I've seen it. But I didn't find a x86_64 version of the tar.xz format. If there is any, I will try to build an adapted package with it.

Comment by: dinolib on Fri, 20 Jan 2017 10:04:10 +0000


Not working with wayland... sad
https://community.teamviewer.com/t5/Tea … 720/page/2

Comment by: Gallaecio on Wed, 30 Nov 2016 09:10:03 +0000


I’ve had to update the checksums and to change the path of the .desktop file to “"${pkgdir}"/opt/${_teamviewerdir}/tv_bin/desktop/com.teamviewer.TeamViewer.desktop”.

Comment by: ahjolinna on Wed, 20 Apr 2016 19:44:18 +0000


 lib32-libxtst is needed for mouse/keyboard to work

Comment by: ahjolinna on Tue, 19 Apr 2016 16:07:54 +0000


v11.0.57095 has arrived

Comment by: Pyrdracon on Tue, 26 Jan 2016 18:36:33 +0000


I've uploaded lib32-libpng12 and added this as a dependency to teamviewer. I started teamviewer before, but I only checked, if it would run at all.
Thanks for your note.

Comment by: sergiocambra on Tue, 26 Jan 2016 12:57:54 +0000


Buttons on application are not displayed. lib32-libpng12 is needed for that, so this package should depend on lib32-libpng12 https://aur.archlinux.org/packages/lib32-libpng12/

Comment by: Pyrdracon on Wed, 06 Jan 2016 00:35:18 +0000


@Gm30: I thought of something like that, but I decided to add a hint, to uninstall teamviewer first, before installing the new version. It's not that easy and I experimented some time, but the Arch way was the easiest approach.

Comment by: Tux83 on Wed, 06 Jan 2016 00:01:41 +0000


Could you add "sudo rm /opt/teamviewer -R" somewhere of CCR to delete the previous version before installing the new?. It is possible?
Thanks for the update.

Comment by: Pyrdracon on Wed, 09 Dec 2015 20:27:16 +0000


If the update doesn't work (file conflicts), please remove Teamviewer 10 before you update.

Comment by: mrcrowley on Wed, 09 Dec 2015 17:38:39 +0000


==> Validazione dei sorgenti con sha256sums in corso...
    teamviewer_linux_x86_64-10.0.46203.deb ... NON RIUSCITO
    fix-winelib.patch ... Verificato
==> ERRORE: Uno o più file non hanno superato il controllo di validità!

Comment by: dinolib on Sat, 19 Sep 2015 09:17:27 +0000


Right now, the sha256sum for the deb package is: f3859b3244284d31fedf0dc04d75bfcf77b770dfe22bb9642c481515bcd23183

Comment by: thotmx on Fri, 24 Apr 2015 17:53:48 +0000


Right now, the sha256sum for the deb package is: a275de854c9ee1cb09f71245454fc939494c75a4129e764fddd462bde1fd5458

Comment by: Pyrdracon on Mon, 02 Feb 2015 06:46:23 +0000


Problem was that Teamviewer does not have a version number with the package. It's corrected now. Thanks for the hint.

Comment by: Tux83 on Sun, 01 Feb 2015 23:37:10 +0000


It's now updated, thanks!. 
Please update the sha256sum code (cc5caf0ac6bac76ac8f40d52ceb533148c9e1a6d61eb542b9a6f0020fd5e7fc8).

Comment by: Pyrdracon on Sun, 01 Feb 2015 20:50:57 +0000


I don't provide the beta package. But I will upload a 64 bit package with the 64 bit dependencies (not the lib32-*...)

Comment by: Tux83 on Sun, 01 Feb 2015 19:59:23 +0000


This CCR uses "64-bit DEB-systems without Multiarch"  and up to now it's version "10.0.35002 Beta"

Only the "with Multiarch" version is "10.0.37742"
(I believe it doesn't work with Chakra).

Comment by: Pyrdracon on Mon, 17 Nov 2014 18:33:15 +0000


I would like to let this version be the stable one. But within a week I will try to upload a 10beta. I need to compare some files though, since without some adjustments 9 does not work and I think, 10 won't, too.

Comment by: ahjolinna on Mon, 17 Nov 2014 17:38:01 +0000


could you update to v10 beta or make different/separate pkg

Comment by: Pyrdracon on Wed, 23 Apr 2014 19:33:17 +0000


I had some problems starting TeamViewer this time. TeamViewer tried to use libwine.so.1 from the installed wine package and refused to start with an error message (wine version mismatch). After compairing some files I exported again the LD_LIBRARY_PATH with the correct libwine.so.1 and TeamViewer works here again.

If there are any problems, please report here, I will see, if I can resolve them.

Comment by: Pyrdracon on Tue, 05 Nov 2013 00:29:19 +0000


The package (8.0.20931) is not outdated, the new package (9.0.23343) is still beta and I will not package this.

Comment by: Pyrdracon on Sun, 03 Nov 2013 16:21:12 +0000


@kurisutian: The config files for teamviewer 8 are in ~/.local/teamviewer8/, but I don't know, if the configuration are completely in this directory. Maybe renaming it helps. There is a drive_c from wine and the registry files for this wine installation (belongs to teamviewer8).

Comment by: kurisutian on Thu, 31 Oct 2013 08:20:49 +0000


@Pyrdracon: No real clue what the logfiles say, but your comment on accepting the license did let me go back and I did once again delete all configs and re-installed teamviewer. After that I wanted to accept the license but the window never came up so I could not agree to it. How am I able to accept it, do you know that?

Comment by: Pyrdracon on Tue, 29 Oct 2013 10:47:09 +0000


@kurisutian: I've tried it here again with a different computer, teamviewer was installed, but not configured, well, the license was not accepted. So the GUI didn't open for this computer, too, when I started the daemon. After this I just opened teamviewer through my konsole, accepted the license and could connect to it without problems. Indeed, very weird.

There should be a logfile (/var/log/teamviewer), does this give you any output?

Comment by: kurisutian on Tue, 29 Oct 2013 10:28:59 +0000


@Pyrdracon: This is indeed weird. I have the daemon running but that never opened the GUI for me (even on an working installation). Also the installation I have is fresh so I doubt that anything interrupts teamviewer from that side. I use it on 3 other computers as well but this one does not work. The major difference is just the newer (and way faster) hardware (i7 CPU, SSD, 32GB DDR3) but anything else is pretty much the same. Also removing teamviewer completely and installing it again does not help.

Comment by: Pyrdracon on Tue, 29 Oct 2013 09:46:03 +0000


@kurisutian: I made now a diff of the two packages, the tar.gz and the deb. The files are all the same, I copied them to their dirs to compare these and the only difference were the symlinks from some directories. No difference in the files itself.

I use the deb file, because all the directories are nearly at the right place, I don't have to copy everything separately into the filesystem, just one command. The last three files I use are the systemd service file and two links: one to the desktop file and one to the LICENSE. That's it. I believe, they said to you to use the tar.gz file, because they don't understand, that it is packaged and prepared for Chakra Linux. I would never install a deb file into my system.

There has to be another reason, why this package won't start. I have no problems using this teamviewer package on at least three computers.

The teamviewer daemon starts teamviewer, too, I don't have to run teamviewer again by hand. The teamviewer icon is in my task bar and I can create a connection to another computer.

Comment by: kurisutian on Tue, 29 Oct 2013 07:40:55 +0000


@Pyrdracon: The deamon is started and I checked the status. If it would not be running, I would have received an error message. But nothing was dropped. It only tells me that teamviewer was launched but then I will be dropped back to the console (if started there) and nothing else is happening. No errors, nothing... and no Teamviewer GUI. That's why I contacted the teamviewer support and they recommended using the tar.gz file. I even copied all teamviewer files over from a working installation but again, nothing worked except the running daemon. So right now the only thing left to do is following their recommendation to use the tar.gz file. Do you think you could change to PKGBUILD to use that file? I personally think it would be better anyway to not use packages from other distros like deb or rpm while valid sources are available. But that's just my personal opinion as I think it looks better to not rely on different package types from other distros (with certain exceptions of course). ;-)

Comment by: Pyrdracon on Mon, 28 Oct 2013 20:46:43 +0000


@kurisutian: Do you have started the teamviewer daemon? Start it with 
# systemctl start teamviewerd

Comment by: kurisutian on Mon, 28 Oct 2013 20:35:20 +0000


Teamviewer won't start for me. I keep starting it from terminal but it refuses to come up. After contacting the support they told me to use the .tar.gz version of the program. Do you think we should use this instead? Could you maybe switch to it? The link they provided it this one: http://download.teamviewer.com/download … nux.tar.gz

Thanks a lot!

Comment by: igor_isaias on Thu, 16 May 2013 09:54:18 +0000


Download error:

  -> Baixando teamviewer_linux_x64-8.0.17147.deb...
--2013-05-16 06:51:27--  http://www.teamviewer.com/download/vers … ux_x64.deb
Resolvendo www.teamviewer.com (www.teamviewer.com)... 46.163.100.220
Conectando-se a www.teamviewer.com (www.teamviewer.com)|46.163.100.220|:80... conectado.
A requisição HTTP foi enviada, aguardando resposta... 302 Found
Localização: https://download.teamviewer.com/downloa … ux_x64.deb [redirecionando]                                                                                    
--2013-05-16 06:51:27--  https://download.teamviewer.com/downloa … ux_x64.deb
Resolvendo download.teamviewer.com (download.teamviewer.com)... 46.163.100.220
Conectando-se a download.teamviewer.com (download.teamviewer.com)|46.163.100.220|:443... conectado.
A requisição HTTP foi enviada, aguardando resposta... 302 Found
Localização: https://downloadus2.teamviewer.com/down … ux_x64.deb [redirecionando]
--2013-05-16 06:51:28--  https://downloadus2.teamviewer.com/down … ux_x64.deb
Resolvendo downloadus2.teamviewer.com (downloadus2.teamviewer.com)... 192.96.200.22
Conectando-se a downloadus2.teamviewer.com (downloadus2.teamviewer.com)|192.96.200.22|:443... falhou: Não há rota para o host.
==> ERRO: Falha enquanto baixava teamviewer_linux_x64-8.0.17147.deb
    Abortando...
The build failed.

Any other link for teamviewer_linux_x64-8.0.17147.deb?

Comment by: NicoDavila on Tue, 09 Apr 2013 14:24:01 +0000


I tried to install, i did but then when i'm trying to launch i get this message and doesn't open:

Launching TeamViewer...
fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:ole:CoInitializeSecurity ((nil),-1,(nil),(nil),0,3,(nil),0,(nil)) - stub!
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:process:SetProcessShutdownParameters (00000100, 00000000): partial stub.
fixme:ntdll:find_reg_tz_info Can't find matching timezone information in the registry for bias 180, std (d/m/y): 0/00/0000, dlt (d/m/y): 0/00/0000
fixme:resource:GetGuiResources (0xffffffff,0): stub
fixme:win:EnumDisplayDevicesW ((null),0,0x33dc60,0x00000000), stub!
fixme:win:EnumDisplayDevicesW (L"\\.\DISPLAY1",0,0x33d918,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),1,0x33dc60,0x00000000), stub!