Username: Password: Remember me
Search - Advanced
Package Details

kicad 5.1.4-1
http://kicad-pcb.org/
Electronic schematic and printed circuit board (PCB) design tools

Category: educational

Submitter: AlmAck
Maintainer: AlmAck
Votes: 5

License: GPL

Last Updated: 2019/08/11 - 13:04:20 +0000
First Submitted: 2013/03/09 - 17:36:29 +0000

Tarball :: PKGBUILD

Dependenciesboost-libs curl glew glm ngspiceopencascade python3 python3-wxpython wxgtk 

Sources

Comment by: AlmAck on Sat, 03 Nov 2018 17:30:47 +0000


The kicad library can be found here:
https://code.chakralinux.org/AlmAck/ccr … ad-library

Comment by: Dax on Sat, 06 Sep 2014 10:47:40 +0000


This patch is needed in order to compile KiCAD: http://paste.kde.org/paqkypaxl

Comment by: Ram-Z on Tue, 12 Nov 2013 23:12:49 +0000


In the following thread we announced that GTK application will no longer reside in /extra.
http://chakra-project.org/bbs/viewtopic.php?id=12118

This package seems to be installed into /extra or depend on filesystem-extra.

Please adapt your PKGBUILD:
1. install into /
2. remove the dependency on filesystem-extra

PS: The list of packages still using /extra has been generated automatically, and this comment sent in bulk. If you think it was sent in error, just ignore it, or contact me or any other TU.

Comment by: leozzo on Fri, 13 Sep 2013 18:30:28 +0000


It doesn't work anymore after libpng update:

kicad: error while loading shared libraries: libpng15.so.15: cannot open shared object file: No such file or directory

Please update the package.

Comment by: yoalieh on Wed, 12 Jun 2013 03:10:18 +0000


sad Now I think I've found a new error in kicad, when trying to load my custom mod libraries, an exception is thrown. Does anyone has this problem too?

Comment by: AlmAck on Mon, 20 May 2013 13:27:00 +0000


updated and moved all kicad-* packages to /extra

Comment by: yoalieh on Mon, 06 May 2013 16:56:31 +0000


changed version from 20130319-BZR4004 to 20130331-BZR4008, and md5sum, an it compiled and works. Does anyone knows how to make this install in the new [extra] hierarchy?

Comment by: yoalieh on Mon, 06 May 2013 04:36:24 +0000


Not longer compiles, expecting version 03-19, only 03-31 version available.