Username: Password: Remember me
Search + Advanced
Package Details

atom-editor 1.10.2-1
https://github.com/atom/atom
Chrome-based text editor from Github

Category: editors

Submitter: twintech.io
Maintainer: None
Votes: 7

License: MIT

Last Updated: 2016/10/06 - 12:07:38 +0000
First Submitted: 2015/07/01 - 18:56:11 +0000

Tarball :: PKGBUILD
This package has been flagged out of date.

Dependenciesalsa-lib desktop-file-utils gconf gtk2 libgnome-keyring libnotify libxtst nodejs nss python2 

Sources

Comment by: James_Che on Mon, 31 Oct 2016 00:07:30 +0000


Hello I can't install it

Ccr Targets    (1): atom-editor

Proceed with installation? [Y/n] 
==> Creando el paquete: atom-editor 1.10.2-1 (dom oct 30 18:59:19 COT 2016)
==> Comprobando dependencias mientras se ejecuta...
==> Comprobando dependencias mientras se compila...
==> Recibiendo las fuentes...
  -> v1.10.2.tar.gz ha sido encontrado 
==> Validando las fuentes con sha256sums...
    v1.10.2.tar.gz ... Aprobado
==> Extrayendo las fuentes...
  -> Extrayendo v1.10.2.tar.gz con bsdtar
==> Eliminando el directorio $pkgdir/...
==> Iniciando build()...
Node: v7.0.0
npm: v3.10.5
Installing build modules...
=> Took 9705ms.

Installing apm...
child_process.js:145
    throw new TypeError('Incorrect value of args option');
    ^

TypeError: Incorrect value of args option
    at Object.exports.execFile (child_process.js:145:11)
    at Object.exports.exec (child_process.js:108:18)
    at Object.<anonymous> (/tmp/ccrbuild-1000/atom-editor/atom-editor/src/atom-1.10.2/apm/node_modules/atom-package-manager/script/postinstall.js:10:16)
    at Module._compile (module.js:573:32)
    at Object.Module._extensions..js (module.js:582:10)
    at Module.load (module.js:490:32)
    at tryModuleLoad (module.js:449:12)
    at Function.Module._load (module.js:441:3)
    at Module.runMain (module.js:607:10)
    at run (bootstrap_node.js:382:7)
npm ERR! Linux 4.5.7-1-CHAKRA
npm ERR! argv "/usr/bin/node" "/tmp/ccrbuild-1000/atom-editor/atom-editor/src/atom-1.10.2/build/node_modules/.bin/npm" "--userconfig=/tmp/ccrbuild-1000/atom-editor/atom-editor/src/atom-1.10.2/build/.npmrc" "--target=4.4.5" "--global-style" "install" "--loglevel" "error"
npm ERR! node v7.0.0
npm ERR! npm  v3.10.5
npm ERR! code ELIFECYCLE

npm ERR! atom-package-manager@1.12.5 install: `node script/postinstall.js`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the atom-package-manager@1.12.5 install script 'node script/postinstall.js'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the atom-package-manager package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node script/postinstall.js
npm ERR! You can get information on how to open an issue for this project with:
npm ERR!     npm bugs atom-package-manager
npm ERR! Or if that isn't available, you can get their info via:
npm ERR!     npm owner ls atom-package-manager
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR!     /tmp/ccrbuild-1000/atom-editor/atom-editor/src/atom-1.10.2/apm/npm-debug.log
npm ERR! code 1
==> ERROR: Se produjo un fallo en build().
    Cancelando...
The build failed.

Comment by: twintech.io on Sun, 27 Dec 2015 05:39:37 +0000


New version.

Comment by: csgib on Fri, 25 Dec 2015 08:09:04 +0000


Could you leave this package, so i can update it ?
Thanks

Stéphane

Comment by: s8321414 on Wed, 07 Oct 2015 14:02:54 +0000


1.0.19 is out

Comment by: alfgaar on Sun, 04 Oct 2015 07:16:07 +0000


This package has some issues to have the app working... it depends on cson-safe, but the maintainer renamed the package to cson-parser and broke compatibility with older versions of the node library.. if you intended to upgrade the package, probably you gonna have to hack the package.json file...

Comment by: twintech.io on Tue, 25 Aug 2015 03:15:52 +0000


Updated.

Comment by: ugjka on Sun, 23 Aug 2015 08:29:57 +0000


1.0.7 is out. Plz update

Comment by: ugjka on Mon, 10 Aug 2015 09:44:23 +0000


1.0.5 is out

Comment by: twintech.io on Mon, 20 Jul 2015 12:25:32 +0000


Updated to the newest version.

Comment by: ugjka on Fri, 17 Jul 2015 12:18:52 +0000


1.0.2 is out!